# KDB Insights Enterprise Error: &quot;Querying database using (Q) raised - Connection reset&quot;

**URL:** <https://forum.kx.com/t/kdb-insights-enterprise-error-quot-querying-database-using-q-raised-connection-reset-quot/13067>\
**Category:** Community Support\
**Tags:** kdb-insights\
**Created:** [November 6, 2023, 11:25am UTC](https://forum.kx.com/t/kdb-insights-enterprise-error-quot-querying-database-using-q-raised-connection-reset-quot/13067 "2023-11-06T11:25:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cperezln1](https://avatars.discourse-cdn.com/v4/letter/c/e47774/32.png) [@cperezln1](https://forum.kx.com/u/cperezln1)\
**Post date:** [November 6, 2023, 11:25am UTC](https://forum.kx.com/t/kdb-insights-enterprise-error-quot-querying-database-using-q-raised-connection-reset-quot/13067/1 "2023-11-06T11:25:00Z")

</div>

Good evening,

I’ve been working on KDB Insights Enterprise to build a demo and I am having problems querying the data.

Once I’ve built the pipeline and database schema (and consequently deployed it) I can query data for a while, but then I get a log fatal error (in the database, not in the pipeline). The mentioned log error is:&nbsp;

{ “time”:“2023-11-06T11:13:03.892z”, “component”:“CONN”, “level”:“FATAL”, “message”:“[eod] Lost connection to eoi”, “service”:“eod”, “container”:“sm”, “pod”:“db-3g-sm-0” }

And the error I am getting:

&nbsp;

And I am not sure how to fix it. Any suggestion? Why is this happening?

&nbsp;

Kind regards,

Cristian

---

<div class="post-metadata">

**Author:** ![gyorokpeter-kx1](https://avatars.discourse-cdn.com/v4/letter/g/d26b3c/32.png) [@gyorokpeter-kx1](https://forum.kx.com/u/gyorokpeter-kx1)\
**Post date:** [November 6, 2023, 11:41am UTC](https://forum.kx.com/t/kdb-insights-enterprise-error-quot-querying-database-using-q-raised-connection-reset-quot/13067/2 "2023-11-06T11:41:00Z")

</div>

Can you check resource usage in your cluster? If you ingest too much data to fit into the memory of the EOI process, it will exit with a memory limit error (-w abort) and be unable to persist your data.

---

<div class="post-metadata">

**Author:** ![cperezln1](https://avatars.discourse-cdn.com/v4/letter/c/e47774/32.png) [@cperezln1](https://forum.kx.com/u/cperezln1)\
**Post date:** [November 6, 2023, 12:13pm UTC](https://forum.kx.com/t/kdb-insights-enterprise-error-quot-querying-database-using-q-raised-connection-reset-quot/13067/3 "2023-11-06T12:13:00Z")

</div>

I cannot, right now I am working remotly and I have no access to the cluster.

I have two questions on that.

- How much is “too much” data? I am sending by Kafka a 32 items dictionary each second, which after the pipeline will be appended as a new row to the table (with 32 columns).
- Is there any way on increasing the memory from Insights Enterpise itself?

Kind regards,

Cristian
